Thursday, June 17, 2010

Getting DWA-140 / RT2870 working on Ubuntu 09.10 Karmic

1. Install the 2.6.34 kernel or newer from Kernel Mainline PPA.
2. Grab the latest RT2870 firmware from RALink's website.
3. Unzip the firmware download & copy the bin to /lib/firmware.

If using an older kernel, you can download the source driver from RALink & compile + install that: remember to copy in the newer firmware .bin file to its "common" subdirectory before installation (or copy to /lib/firmware afterwards).

1 comment:

  1. Hey buddy. Do you give you can guide a newbie through this?

    I've been struggling for days with getting my dwa-140 ver.1 working with Ubuntu 10.04

    ...and still no luck :-(

    ReplyDelete